Rational ClearQuest®

Introduction

VERSION: 2002.05.00
PART NUMBER: 800-025123-000
WINDOWS/UNIX
IMPORTANT NOTICE

COPYRIGHT
Copyright ©1997-2002, Rational Software Corporation. All rights reserved.

Part Number: 800-025123-000

Version Number: 2002.05.00

PERMITTED USAGE
This document contains proprietary information which is the property of Rational Software Corporation (“Rational”) and is furnished for the sole purpose of the operation and the maintenance of products of rational. No part of this publication is to be used for any other purpose, and is not to be reproduced, copied, adapted, disclosed, distributed, transmitted, stored in a retrieval system or translated into any human or computer language, in any form, by any means, in whole or in part, without the prior express written consent of rational.

TRADEMARKS
Rational, Rational Software Corporation, Rational the e-development company, ClearCase, ClearCase Attache, ClearCase MultiSite, ClearDDTS, ClearQuest, ClearQuest MultiSite, DDTS, Object Testing, PureCoverage, PureDDTS, PureLink, Purify, Purify’d, Quantify, Rational Rose, Rational Suite, Rational Visual Test, Requisite, RequisitePro, RUP, AnalystStudio, ClearGuide, ClearTrack, Connexis, Rational Suite AnalystStudio, Rational Suite ContentStudio, Rational Suite Enterprise, Rational Suite ManagerStudio, Rational Unified Process, TestStudio, among others, are either trademarks or registered trademarks of Rational Software Corporation in the United States and/or in other countries. All other names are used for identification purposes only, and are trademarks or registered trademarks of their respective companies.

Microsoft, the Microsoft logo, Active Accessibility, Developer Studio, Direct3D, FrontPage, J/Direct, JScript, the Microsoft eMbedded Visual Tools logo, the Microsoft Internet Explorer logo, the Microsoft Office Compatible logo, Microsoft Press, the Microsoft Press logo, MS-DOS, MSDN, the Office logo, Outlook, PhotoDraw, PowerPoint, SourceSafe, Visual C++, Visual J++, Visual SourceSafe, Visual Studio, the Visual Studio logo, Win32, Win32s, Win64, Windows, the Windows CE logo, the Windows logo, Windows NT, the Windows Start logo, and XENIX are trademarks or registered trademarks of Microsoft Corporation in the United States and other countries.

The Sun J2EE Patterns are used with permission from the book “Core J2EE Patterns” by Deepak Alur, John Crupi, and Danny Malks, published by Sun Microsystems Press/Prentice Hall. Copyright 2001 Sun Microsystems, Inc., 901 San Antonio Road, Palo Alto, CA 94303. All rights reserved. SUN PROVIDES EACH J2EE PATTERN
"AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

FLEXlm and GLOBEtrotter are trademarks or registered trademarks of GLOBEtrotter Software, Inc. Licensee shall not incorporate any GLOBEtrotter software (FLEXlm libraries and utilities) into any product or application the primary purpose of which is software license management.

Portions Copyright ©1992-2001, Summit Software Company. All rights reserved.

PATENT

Purify is licensed under Sun Microsystems, Inc., U.S. Patent No. 5,404,499.

GOVERNMENT RIGHTS LEGEND
Use, duplication, or disclosure by the U.S. Government is subject to restrictions set forth in the applicable Rational Software Corporation license agreement and as provided in DFARS 277.7202-1(a) and 277.7202-3(a) (1995), DFARS 252.227-7013(c)(1)(ii) (Oct. 1988), FAR 12.212(a) (1995), FAR 52.227-19, or FAR 227-14, as applicable.

WARRANTY DISCLAIMER
This document and its associated software may be used as stated in the underlying license agreement. Rational Software Corporation expressly disclaims all other warranties, express or implied, with respect to the media and software product and its documentation, including without limitation, the warranties of merchantability or fitness for a particular purpose or arising from a course of dealing, usage, or trade practice.
Contents

1 Welcome to Rational ClearQuest ........................................ 1
   What is ClearQuest? .................................................. 2
   Ready-to-use defect tracking system ................................ 3
   Support for your development environment .......................... 3
   Where to get more information ...................................... 4

2 On the job with ClearQuest ........................................... 5
   Getting started .................................................... 6
   Getting around in ClearQuest ....................................... 7
   Submitting a change request ....................................... 8
   Receiving automatic e-mail notification ............................ 9
   Working with change request records ............................... 10
   Assigning a change request ....................................... 10
   Modifying a change request ....................................... 11
   Opening and resolving a change request .......................... 11
   Tracking change request records .................................. 12
   Using public queries ................................................ 12
   Modifying queries .................................................. 13
   Building a new query .............................................. 13
   Gathering project metrics ......................................... 14
   Using ClearQuest charts .......................................... 14
   Creating reports from ClearQuest data ............................ 15

3 Administering and customizing ClearQuest ............................ 17
   Overview of ClearQuest databases and schemas .................... 17
   Starting ClearQuest Designer ...................................... 19
   Customizing a schema ............................................. 20
   Checking out the schema .......................................... 22
   Adding a new state ................................................ 22
   Creating a new field .............................................. 25
   Defining the behavior of the new field ............................ 26
   Adding the new field to the record form .......................... 27
   Creating an action hook .......................................... 28
   Checking in the schema .......................................... 29
   Working with the new record form ................................ 30
   Selecting a ClearQuest schema .................................... 31
Index .................................................... 33
Welcome to Rational ClearQuest

ClearQuest is a customizable defect and change tracking system designed for the dynamic environment of software development. With ClearQuest, you can manage every type of change activity associated with software development, including enhancement requests, defect reports, and documentation modifications.

ClearQuest shortens development cycles by unifying your entire team in the process of managing software change:

- **Development engineers** can identify and prioritize action items that pertain to their section of code.
- **Test engineers** can track the status and resolution of change requests to verify software quality.
- **Project leaders** and **managers** can get information at a glance to help them allocate development resources, streamline workflow, and accurately determine release dates.
- **Administrators** can integrate ClearQuest with existing tools and customize it to fit your organization’s workflow.

This guide provides an overview of how to use ClearQuest on the job and a brief example of how your ClearQuest administrator can customize ClearQuest to fit your workflow. For instructions on how to install ClearQuest, see the *Installing Rational ClearQuest* guide that came with your product.
What is ClearQuest?

ClearQuest consists of several components that work in a client-server environment.

<table>
<thead>
<tr>
<th>Component</th>
<th>Used by</th>
<th>Use to</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Client tools</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ClearQuest for Windows</td>
<td>Everyone</td>
<td>Submit, modify, and track change requests, and to analyze project progress by creating and updating queries, charts, and reports.</td>
</tr>
<tr>
<td>ClearQuest for UNIX</td>
<td>Everyone</td>
<td>Submit, modify, and track change requests, and support project analysis by creating and updating queries.</td>
</tr>
<tr>
<td>ClearQuest Web</td>
<td>Everyone</td>
<td>Access ClearQuest across multiple platforms through Netscape Navigator® or Microsoft's Internet Explorer to submit, modify, and track change requests, and support project analysis by creating and updating queries and reports.</td>
</tr>
<tr>
<td><strong>Administrator tools</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ClearQuest Designer</td>
<td>ClearQuest administrator</td>
<td>Customize ClearQuest, manage ClearQuest schemas and databases, and administer users and user groups.</td>
</tr>
<tr>
<td>ClearQuest Import Tool</td>
<td>ClearQuest administrator</td>
<td>Import data including records, history, and attachments from other change request systems and between ClearQuest databases.</td>
</tr>
<tr>
<td>ClearQuest Export Tool</td>
<td>ClearQuest administrator</td>
<td>Export ClearQuest data from one ClearQuest user database to another user database.</td>
</tr>
<tr>
<td>ClearQuest Maintenance Tool</td>
<td>Everyone</td>
<td>Set up and connect to the schema repository during installation and when you upgrade to a new ClearQuest version.</td>
</tr>
<tr>
<td>Rational E-mail Reader</td>
<td>ClearQuest administrator</td>
<td>Enable ClearQuest users to submit and modify records by e-mail. For more information, see Chapter 9, “Administering ClearQuest E-mail” in Administering Rational ClearQuest.</td>
</tr>
</tbody>
</table>
Ready-to-use defect tracking system

ClearQuest includes predefined schemas that provide ready-to-use change and defect tracking processes and integration with various Rational Software products. You can use ClearQuest schemas as is or customize them to fit your organization’s workflow. For a list of ClearQuest predefined schemas, see “Selecting a ClearQuest schema” on page 31.

Support for your development environment

ClearQuest provides the following support for your software development environment:

- Supports Microsoft Access® (included with ClearQuest), Sybase SQL Anywhere (included with ClearQuest), Microsoft SQL Server®, Oracle relational databases, and IBM DB2.
- Integrates with Rational ClearCase and Microsoft Visual SourceSafe so you can associate change requests directly with changes in your evolving software.
- Integrates with Rational TeamTest, VisualTest, Purify, PureCoverage, and Quantify, allowing you to submit change requests to ClearQuest directly from these testing tools.
- Includes Seagate’s Crystal Reports Professional Edition™ so you can create custom reports from ClearQuest data.
- Allows you to integrate with other standard Windows tools, such as Microsoft Excel and Word through an advanced COM interface.
- Provides access to Rational Unified Process through the ClearQuest Help > Rational Extended Help menu.
- Supports Microsoft IIS web server.
Where to get more information

ClearQuest includes the following documentation:

Start Here

ClearQuest Introduction
ClearQuest Help
ClearQuest Designer Tutorial

Designers
ClearQuest Administrator's Guide
ClearQuest API Reference

Administrators
ClearQuest Release Notes
ClearQuest Installation
ClearQuest Administrator's Guide
ClearQuest MultiSite Administrator's Guide
ClearQuest Multiutil Help

4 Chapter 1 - Welcome to Rational ClearQuest
On the job with ClearQuest

This chapter is for all ClearQuest users. It introduces the basic concepts of using ClearQuest, including information on how to:

- Submit a change request.
- Work with change requests.
- Track change requests.
- Gather project metrics.

If you’re reading this chapter as a ClearQuest administrator, look for the ClearQuest Designer icon next to suggestions for how you can customize ClearQuest to fit your organization’s workflow. For more information, read “Administering and customizing ClearQuest” on page 17.

Note: The examples in this chapter show the DefectTracking schema and SAMPL database that are included with ClearQuest. This represents only one model for using ClearQuest. For more information, see “Selecting a ClearQuest schema” on page 31.
Getting started

To start using ClearQuest:

1  Select **Rational ClearQuest** from the Start menu.

2  Log into ClearQuest. You can use the ClearQuest predefined user name (admin) to get started. You do not need to type a password.

Select the **SAMPL** database to experiment with a working user database that already contains many change request records.

During installation, you create and configure user databases for your site; their names appear in the drop-down list of databases when users log in. See *Installing Rational ClearQuest*. You use ClearQuest Designer to set up user login accounts and to define user access privileges. See Chapter 6, “Administering users” in the *Administering Rational ClearQuest* guide.
Getting around in ClearQuest

The ClearQuest main window consists of a Workspace, a Query Builder, and a Record form.

The Workspace lists the queries, charts, and reports that are available.

Double-click a query to locate records in the database.

Use the Record form to view and to modify records.

Scroll through multiple records from the same query or type the number of the record you want to locate.

The Public Queries folder in the Workspace contains the queries, charts, and reports that are included in ClearQuest, as well as any that your ClearQuest administrator creates. You can drag any query, chart, or report to your Personal Queries folder and modify it to suit your needs.

You can click Print to print a single record. To do this you must have a report format associated with the record type. Look up Print Single Record in the ClearQuest Designer Help index.

For more information, select Help > Contents > Getting around ClearQuest.
Submitting a change request

You begin using ClearQuest by submitting a change request. This creates a record in the user database that everyone on the team can track as your software development and testing evolves.

To submit a change request, click **New Defect** in the toolbar.

Use the various tabs on the Submit Defect form to describe the change request in detail, including attaching code fragments and other supporting information. Some tabs contain fields that are mandatory. For example, the Headline field requires a short sentence describing the problem, and you must select a value for the Severity field.

You can save frequently used field values as defaults so you don’t have to re-enter them each time you submit a change request. Fill in the fields you want to save and select **Values > Save as Default**.

**Note:** You can submit a change request directly to ClearQuest from Rational TeamTest, Purify, PureCoverage, Quantify, and Visual Test. You can also use ClearQuest Web and ClearQuest UNIX to submit and modify change requests or submit change requests via email.

As a ClearQuest administrator, you can create additional record types. For example, you might want separate record types for hardware defects, software defects, and enhancement requests. You can also customize record
forms, including adding tabs and fields and defining their behavior. See Chapter 5, “Customizing a schema” in the *Administering Rational ClearQuest* guide.

For more information, select **Help > Contents > Working with records**.

**Receiving automatic e-mail notification**

Your ClearQuest administrator can configure ClearQuest to automatically send e-mail to various team members when a change request is submitted or changed. To take advantage of automatic e-mail notification, all ClearQuest users must set up their e-mail options. Select **View > E-mail Options**.

For more information, select **Help > Contents > Using ClearQuest > Setting up e-mail notification**.

ClearQuest’s Email_rule record type makes it easy to define the rules for sending automatic e-mail notification to ClearQuest users. The Email_rule record type is part of the E-mail package included in every ClearQuest out-of-the-box schema. You can also use the Rational E-mail Reader to configure your e-mail settings so that ClearQuest users can submit and modify records by e-mail.

For more information, in ClearQuest Designer, select **Help > Contents > Using e-mail features**. Read Chapter 9, “Administering ClearQuest E-mail” in the *Administering Rational ClearQuest* guide.
You work with change request records by moving them through various stages, or “states.” In each state, you can perform actions such as modifying the record or moving it to another state. The Actions menu lists the actions that you can perform on the record while it is in any given state.

Here’s an example of a typical workflow:

Assigning a change request

A change request record usually starts out in the Submitted state. The first thing to do is to assign the change request to the engineer responsible for that section of code.

The Assign action changes the state of the record to Assigned.

The exact process of working with records, including the states the record can be in and the actions available in each state, depends on the ClearQuest schema you are using and any customizations you have made to it. See “” on page 19.
Modifying a change request

Not all actions change the state of a change request. You can select **Actions > Modify** to change some information on a change request without actually changing its state.

Opening and resolving a change request

If you’re the engineer assigned to the change request, you begin work by selecting **Actions > Open**. This changes the record’s state to Opened; now the rest of the team can see that you’re working on the problem.

When you finish your work, select **Actions > Resolve** to change the record’s state to Resolved.

In this example, the ClearQuest administrator has configured ClearQuest to send an automatic e-mail notification to the Quality Assurance team as part of the Resolve action. A quality assurance engineer can then verify that the problem is fixed and change the record state to Closed.

As a ClearQuest administrator, you can restrict actions to specific user groups. For example, you might allow everyone on the team to resolve a change request, but restrict the Verify action to members of the Quality Assurance group.
Tracking change request records

ClearQuest queries make it easy for everyone on your team to track change request records as they move through your system.

Using public queries

ClearQuest includes ready-to-use queries that help you locate records by project or component, by assigned engineer, by level of severity, and so on. For example, when you discover a defect in your software, you can check to see if the defect has already been submitted. Select Public Queries > All Defects to display all the records in the database, or use the Keyword search query to locate records containing a specific word in the Headline or Description field.

These records are the result of a keyword search for records containing the word sale.

During a session of submitting new defects, you can select Query > RecentlySubmitted to see a list of the defects you have submitted since you logged in.
Modifying queries

To modify a query, first drag the query to your Personal Queries folder and then use the Query editor and Display editor tabs.

Building a new query

To build a new query from scratch or from an existing query, select Query > New Query. The ClearQuest Query Wizard steps you through the process of building a query.

For more information, select Help > Contents > Working with queries.

As a ClearQuest administrator, you can save queries to the Public Queries folder and can assign this privilege to other users.

See Chapter 6, “Administering users” in the Administering Rational ClearQuest guide.
Gathering project metrics

ClearQuest provides predefined charts and reports that you can run on Windows and on ClearQuest Web to view the status of your project at a glance. On Windows, you can modify these charts and reports to fit your own needs. ClearQuest UNIX does not support the creation of charts or reports.

Using ClearQuest charts

ClearQuest charts display record data graphically. Distribution charts show the current status of data; trend and aging charts show historical information.

For example, you can see how the workload is distributed among the engineers on your team by running a distribution chart that displays the defects assigned to each engineer. Or, you can see the defect records graphed by state and severity.

There are two ways to modify the contents of a chart: Select **Edit > Properties** to define how the data is displayed, or use the Query editor tab to filter the records included in the chart.
Creating reports from ClearQuest data

ClearQuest includes reports and report formats that you can use to create reports from ClearQuest data. To create a report on the current query results set, first run a query such as All Defects, then click to open the Create Report dialog.

This creates a report in the selected format from the data in the query result set. Click to export the report output to another format, such as HTML or Excel.
To create a new report that you can reuse, run a query that you want to create a report from, and then select **Query > New Report**.

Select a **record type**

Select a **report format**

Select a **query**

This creates a report from the query data you selected. You can save this report in your Personal Queries folder and run it at any time.

You can use Crystal Reports Professional Edition to create new report formats. You can save these formats in your Personal Queries folder and use them to format ClearQuest reports.

For more information, see **Help > Contents > Working with reports**.

Now you’re ready to put ClearQuest to work. Remember that ClearQuest Help contains detailed information to assist you every step of the way. For context-sensitive Help, click ![Help icon](image.png) and then click the item you want information about.

Be sure to read the next chapter, “Administering and customizing ClearQuest.”

---

**Chapter 2 - On the job with ClearQuest**
This chapter is for ClearQuest administrators. It begins with an overview of ClearQuest databases and schemas, then provides a brief example of how to perform the primary task of an administrator—customizing a ClearQuest schema to fit your workflow.

Note: For complete information about administering ClearQuest, including a description of how to get your ClearQuest users up and running, see the Administering Rational ClearQuest guide that came with your ClearQuest product. To take the tutorial, select ClearQuest Designer Tutorial from the Start menu.

**Overview of ClearQuest databases and schemas**

A ClearQuest schema contains the metadata that defines the process for how users work with records in ClearQuest. It includes:

- Record type definitions.
- Forms used to submit and modify a record.
- Field definitions and behavior.
- States a record can be in.
- Actions used to modify or change the state of a record.
- Hooks written in Visual BasicScript™ or Perl that further customize fields and actions.

Note: ClearQuest includes several predefined schemas that you can use as is or customize to fit your workflow. For a list of these schemas, see “Selecting a ClearQuest schema” on page 31.

ClearQuest stores schemas in a schema repository. A ClearQuest installation usually consists of one schema repository and one or more user databases. You can have separate user databases for each project, or group several
projects together into one database. If you want to generate reports and charts across several projects, you should put the projects in the same database. Projects that share a database must use the same schema.

Here's an example of how a schema repository with two schemas can work with several user databases:

Note: Once a database is associated with a schema, it can only be upgraded with a newer version of that same schema. It cannot use an older version of the schema or a completely different schema.

In the above example, you can:

- Upgrade the databases for projects X, Y, or Z with newer versions of the DefectTracking schema.
- Upgrade the Test database with newer versions of the myschema schema.
- Apply any version of the DefectTracking schema or the myschema schema to a new database.

For a complete description of how to work with schemas and databases, see Chapter 4, “Working with ClearQuest schemas” in the Administering Rational ClearQuest guide.
Starting ClearQuest Designer

To start ClearQuest Designer:

1. Select **Rational ClearQuest Designer** from the Start menu.

   ClearQuest provides a default User Name (*admin*) that you can use to get started. Do not type in a password. The *admin* user account is set up with the access privileges you need to perform all ClearQuest administrator functions. To change the *admin* account, select **Tools > User Administration**, then select the *admin* user and click **Edit**.

   For more information on user-access privileges, see Chapter 6, “Administering users” in the *Administering Rational ClearQuest* guide.

2. ClearQuest Designer displays the Open Schema dialog.
   Check out a schema if you are planning to modify it and click **Finish**; otherwise click **Cancel** to continue.
Customizing a schema

This section provides a brief example of how to customize a schema. Suppose you have a simple defect record with only two states (Submitted and Closed) and three actions (Submit, Modify, and Resolve). The process of working with this record is shown in the state model below:

The defect record begins in the Submitted state; from there you can select **Actions > Resolve** to change the record state to Closed, or **Actions > Modify** to modify the record without changing its state. The record form looks like this:

The process of working with a record, along with the record form and fields, is defined by the ClearQuest schema.
In this example, you modify the process of working with the defect record by adding an Opened state so that the state model looks like this:

To customize the schema to fit this new workflow, you will:

- Add a new action, *Open*, that changes the state of the record from Submitted to Opened.
- Add a field, *planned_fix_date*, to the record form.
- Define the behavior of the *planned_fix_date* field.
- Create a Visual Basic hook that automatically sets the *planned_fix_date* field equal to three days from today’s date.
Checking out the schema

To customize a schema, you must first check it out of the schema repository. Select File > Open Schema. For complete instructions on working with schemas, including setting up a test database to test your schema customizations, see Chapter 4, “Working with schemas,” in the Administering Rational ClearQuest guide.

Adding a new state

The ClearQuest Designer State Transition Matrix shows the various states that a record can be in and the actions that move the record from one state to another. In this example, it shows that the Resolve action changes the record from the Submitted state to the Closed state.

To add a new state, open the State Transition Matrix and then select Edit > Add State.

For more information, look up states, creating in the ClearQuest Designer Help index.
Adding a new action

The Actions grid shows all of the actions that can be performed on a record. To add a new action, you first add the action to the Actions grid and then associate it with the appropriate states.

This adds the Open action to the ClearQuest Actions menu. Now, when the record is in the source state (Submitted), you can select Actions > Open to move the record to the destination state (Opened).

You should also modify the existing Resolve action to add Opened as a legal source state.
Look at the State Transition Matrix again. It now shows that the Open action moves the record from the Submitted state to the Opened state, as intended.

You can see how the State Transition Matrix implements the new state model.

In the Submitted state, you can select Actions > Open to change the state to Opened. In both the Submitted state and the Opened state, you can select Actions > Resolve to change the record to Closed.

For more information, look up state transitions in the ClearQuest Designer Help index.
Creating a new field

Now, create a new field for the record form called `planned_fix_date` that lets you enter the date when you expect to resolve the defect.

To create a new field, open the Fields grid. The Fields grid shows all of the fields on the record form, their type, and their default values.

Double-click to open the Fields grid

Type `planned_fix_date` in the Field Name column

Click the Type column and select Date_Time as the field type

For more information, look up `fields, adding to schemas` in the ClearQuest Designer Help index.
Defining the behavior of the new field

The Behaviors grid shows how fields behave when the record is in each state. You can define whether a field is read-only, mandatory, or optional in each state, or define default behavior for all states. You can also create a use-hook behavior that restricts user access to the field. For more information, refer to the ClearQuest API Reference.

Open the Behaviors grid, then right-click and use the popup menu to define the behavior of the planned_fix_date field.

For more information, look up fields, behaviors in the ClearQuest Designer Help index.
Adding the new field to the record form

After creating a field, you must add it to the record form. To add the planned_fix_date field to the record form, open the Defect form. In the Workspace, select Record Types > Defect > Forms > Defect.

Use the Controls Palette to add controls such as check boxes and option buttons to a form.

1. Double-click to open the Defect record form

2. Drag the planned_fix_date field onto the form

3. Right-click the text box and select Properties from the popup menu

4. Use the Property Sheet to change the text box properties

5. When you finish, close the form window

For more information, look up controls, adding to forms in the ClearQuest Designer Help index.
Creating an action hook

Hooks are triggers for pieces of code that ClearQuest executes at specified times to more fully implement your workflow. ClearQuest provides many predefined hooks that you can easily modify to suit your needs. You can also use the ClearQuest application programming interface (API) to write hook code in Microsoft VBScript or Perl.

ClearQuest supports four types of hook code:

- Field hooks provide a way to validate the contents of a field or to assign field values.
- Action hooks implement tasks at key points in the life cycle of a record.
- Record scripts allow you to associate a hook with a control, such as a push-button or shortcut menu option, on a single record.
- Global scripts allow you to reuse hook code in other hooks.

In this example, you modify the predefined ACTION_INITIALIZATION hook for the Open action so that it initializes the value of the planned_fix_date field.

This opens the ClearQuest Script Editor.
Use the ClearQuest Script Editor to edit the ACTION_INITIALIZATION hook so that it initializes the value of the planned_fix_date field to the current date + three days.

Add these lines to the script:

```vbnet
three_days = Now + 3
Call SetFieldVal("planned_fix_date", three_days)
```

For more information, look up hooks, overview in the ClearQuest Designer Help index. Read Chapter 7, “Using hooks to customize your workflow,” in the Administering Rational ClearQuest guide.

**Checking in the schema**

At any time while working on a schema, you can select File > Test Work to test your work in progress. This upgrades the test database with your latest changes, providing a quick way to test your changes in the ClearQuest client without affecting your production user database.

When you’re satisfied that your schema changes are working correctly, select File > Check in to check the schema into the schema repository. Once the schema is checked in, you can use it to upgrade your user database. Select Database > Upgrade Database. ClearQuest prompts you to back up the schema repository and the database before upgrading.

For more information, read Chapter 4, “Working with schemas,” in the Administering Rational ClearQuest guide.
Working with the new record form

After upgrading the user database with the customized schema, the defect record form works like this:

When the record is in the Submitted state...

...click Open to change the record state to Opened

The Open action changes the state of the record to Opened and automatically fills in the planned_fix_date field.

The record state changes to Opened

The planned_fix_date field is filled in automatically
Selecting a ClearQuest schema

Below is a list of the predefined schemas that are included in ClearQuest. ClearQuest schemas consist of various packages that provide specific functionality. You can add individual packages to an existing ClearQuest schema or to your own customized schema. For complete descriptions of ClearQuest schemas and packages, see your Administrating Rational ClearQuest guide.

<table>
<thead>
<tr>
<th>Schema</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blank</td>
<td>Contains only system fields. Use this schema to create a schema from scratch.</td>
</tr>
<tr>
<td>Common</td>
<td>Contains metadata that is common to all of the ClearQuest schemas.</td>
</tr>
<tr>
<td>DefectTracking</td>
<td>Contains the fields necessary to start using ClearQuest to track defects in a software-development environment.</td>
</tr>
<tr>
<td>Enterprise</td>
<td>For use with Rational Suite EnterpriseStudio. Contains fields and hooks that work with all Rational products.</td>
</tr>
<tr>
<td>TestStudio</td>
<td>Compatible with Rational Suite TestStudio. Contains fields and rules that work with Rational TeamTest, RequisitePro, Purify, Quantify, and PureCoverage.</td>
</tr>
<tr>
<td>UnifiedChangeManagement</td>
<td>Supports the UCM process by providing integration with Rational ClearCase.</td>
</tr>
</tbody>
</table>

Now, you’re ready to begin using ClearQuest Designer. Remember that ClearQuest Designer Help contains detailed information to assist you every step of the way. For context-sensitive Help, click ? and then click the item you want information about.
Index

A

actions
   adding new 23
   and state model diagram 20, 21, 24
   and states 10
   defined in schema 17
   hook 28
   modifying 11
   open 11
   properties 23
   restricting user access to 11
   admin user ID 19
   administering ClearQuest 17
   aging charts 14
   AnalystStudio schema 31
   API, ClearQuest 28
   assign action 10
   assigned state 10

B

behavior, field 26
Blank schema 31

C

change requests, <Emphasis>see records
charts 14
   distribution and aging 14
   for multiple projects 18
   modifying 14
   checking in a schema 29
   checking out a schema 19
   ClearCase support 3
   ClearQuest
      administrator tools 2
      client tools 2
      ClearQuest Designer 2
      starting 19

tutorial 17
   ClearQuest Web 2
   Common schema 31
   Crystal Reports support 3, 16

D

data
   creating reports from 15
   graphing 14
   tool for importing 2
databases
   and schemas 18
   maintenance tool 2
   querying 12
   SAMPL 5, 6
   selecting at login 6
   tool for exporting data 2
   tool for importing data 2
   upgrading with a schema 18, 29
   user 17
defect
   form 27
   resolving 11
   submitting new 8
   DefectTracking schema 5, 31
   Designer, starting ClearQuest 19
destination state 23
   DevelopmentStudio schema 31
display editor 13
distribution charts 14
drill down in a chart 14

E

editor
   query 13
   script 28
e-mail, automatic 9, 11
   Email_rule record type 9
E-Mailreader tool 2
Enterprise schema 31
Excel support 3
Export Tool, ClearQuest 2

F
fields
   adding to a form 27
   creating new 25
   default values 8
   defined in schema 17
   defining behavior 26
   hooks for 28
   labeled red 8
   required 8
   filtering records 12, 14
   fixing defect 11
   folders, workspace 7
   format, report 15
   forms
      adding field to 27
      defect 27
      defined in schema 17

G
global scripts 28
graphs 14

H
headline field 8
hooks 17, 28

I
ID, built-in user
   for ClearQuest 6
   for ClearQuest Designer 19
Import Tool, ClearQuest 2
initialization hook 28

installing ClearQuest 1

K
keyword search query 12

L
logging into a database 6
login
   ClearQuest 6
   ClearQuest Designer 19

M
maintenance tool for databases 2
mandatory fields 8, 26
menu, shortcut 14
metadata 17
metrics, project 14
Microsoft Word support 3
modifying a change request 11

N
New Defect tool 8

O
opened state 11
optional field 26

P
packages, schema 31
Perl scripting language 17, 28
Personal Queries folder 7
print a single record 7
Public Queries folder 7, 12
PureCoverage support 3
Purify support 3
Q

Quantify support 3
queries
  default 7
  keyword search 12
  modifying 13
  new 13
  personal 13
  public 12
  recently submitted 12
Query Builder 7
Query Editor 13, 14
Query Wizard 13
querying the database 12

R

Rational E-Mail Reader 2
read-only field 26
recently submitted queries 12
record type, Email_rule 9
record(s)
  assigning 10
  definition of 8
  filtering 14
  filtering with queries 12
  finding 12
  form 7
  printing single 7
  recent 12
  scripts 28
  submitting 8
  tracking 12
red field labels 8
reports 15
  creating new 16
  for multiple projects 18
  format 15
  reusable 16
repository, schema 17
required fields 8
resolved state 11
restricting user access to actions 11
result set 12

and reports 15

S

SAMPL database 5, 6
schema repository 17
elementary of 18
schemas
  checking in 29
  checking out 19
  customizing 20
  customizing predefined 31
  defined 17
  packages 31
  predefined 31
  repository 17
Script Editor 28
scripts
  global 28
  languages for 28
  record 28
search, keyword 12
severity
  field on record form 8
  graphing data by 14
shortcut menu 14
source state 23
state model diagram 20, 21, 24
state transition matrix 22
states
  adding new 22
  and actions 10
  changing 10
  defined in schema 17
  destination 23
  opened 11
  resolved 11
  source 23
submitting a change request 8

T

TeamTest support 3
TestStudio schema 31
tracking change requests 12
transition matrix, state 24
trend charts 14
tutorial, ClearQuest Designer 17

U
UnifiedChangeManagement schema 31
UNIX, ClearQuest for 2
upgrading databases 18
user database 17
user ID
  for ClearQuest 6
  for ClearQuest Designer 19
user privileges
  and actions 11

V
values, default field 8
Visual Basic Script hooks 17, 28
VisualTest support 3

W
Web, ClearQuest 2
Windows, ClearQuest for 2
Wizard, Query 13
Workspace 7

X
X on tabs 8